I HAVE A 4

  • Tiny
  • Flash25205
  • 1988 CHEVROLET S-10
  • 200,000 MILES

I have a 4.3 motor automatic transmission the transmission works untill I start going downhill and then the transmission acks like it is go in netural, you can downshift and it will not slow the truck down, I can give it gas and sometimes it will engage the transmission again, Once I get on level ground or up hill it starts working good again. You can go backward down a hill and it works great. You have to have really good brakes when you go down a hill. Any help thanks

Do you
have the same problem?
Yes
No
Sunday, November 18th, 2012 AT 3:17 AM

3 Replies

  • Tiny
  • Rasmataz
  • MEMBER

With that mileage-Let me ask you this -How long since you have the transmission serviced-don't recall check the tranny fluid level and condition -start here and then report back -

Was this
answer
helpful?
Yes
No
Sunday, November 18th, 2012 AT 3:50 AM
  • Tiny
  • Flash25205
  • MEMBER

Just bought the truck so un sure about the service part, checked the fluid it looks good and full

Was this
answer
helpful?
Yes
No
Sunday, November 18th, 2012 AT 1:07 PM
  • Tiny
  • Rasmataz
  • MEMBER

How did you check the fluid? If you're checking it like the oil its not the correct way-recheck it and make sure the engine is in normal operating temperature and idling while you check the level-Filter could be clogging-who knows-if it continues bring it in to a transmission specialty shop and have it pressure tested this will give you the direction where to start the diagnosis-possibilities the detent cable out of adjustment, governor, sticking solenoid and a clogged valve body etc-

Was this
answer
helpful?
Yes
No
Sunday, November 18th, 2012 AT 9:07 PM

Please login or register to post a reply.

Other Transmission Downshift Questions