HOW TO FIX MY TRANSMISSION?

1987 Oldsmobile Cutlass

Tiny

earl4

June, 11, 2012 AT 12:34 AM

I have a 5.0 350 I think or 307 motor and idk the tranny but wen I put it in drive and press the gas it dosent move unless I press like 3 or 4 times and then it catches and rides but rattles under the car you could hear it and feel it then when it goin in to second gear it revs and gains speed slowly then and it takes a few seconds longer than it should to switch to third then in third it ride well what may be my problem?

FOUND 3059 RELATED QUESTIONS

12 Answers

Tiny

saturntech9

June, 11, 2012 AT 12:40 AM

Have you checked the fluid level yet?Sounds like a internal failure.

Tiny

earl4

June, 11, 2012 AT 3:01 AM

Yea it has a slow leak from the front of the pan but it dosent leak all the way out what else may be the problem

Tiny

CJ MEDEVAC

June, 11, 2012 AT 4:13 AM

I DIDN'T HAVE THE "PROPER" NOMENCLATURE OF YOUR VEHICLE OR ENGINE SIZE --- I WENT WITH "SUPREME AND 307"

HOW LONG AGO DID YOU CHANGE THIS???

http://shop.advanceautoparts.com/webapp/wcs/stores/servlet/product_Automatic-Transmission-Filter-Kit-Pro-King_5152275-P_1158_R%7CGRPFILTAMS_____

THIS MAY NOT BE YOUR FIX---BUT IT IS "SCHEDULED MAINTENANCE".....IT VERY WELL COULD BE THE PROBLEM/ PART OF THE PROBLEM

RUNNING IT LOW ON FLUID (EVEN IF YOU DID REFILL IT) MIGHT NOTTA MADE MR. TRANNY REAL HAPPY EITHER......THAT'S KINDA LIKE RUNNIN' MR. ENGINE 4 QUARTS LOW ON OIL.....IT MAY STILL RUN AFTER IT'S REFILLED, BUT THE DAMAGE MAY ALREADY BE DONE, WITH CRITICAL PARTS HAVING STARVED FOR LUBRICATION.

KEEP US INFORMED ON YOUR DILEMMA

THE MEDIC

Tiny

saturntech9

June, 11, 2012 AT 6:39 AM

You can also drop the transmission pan and look for a debris in the pan.

Tiny

earl4

June, 11, 2012 AT 11:05 AM

I put fluid in there but it leaks all out and wen I check the dipstick it says add one pint everytime I put sum in there that what it does what else may be my problem

Tiny

earl4

June, 11, 2012 AT 11:07 AM

I changed the filter and the gasket about a month ago

Tiny

saturntech9

June, 11, 2012 AT 5:40 PM

Was there a lot of debris in the pan when you changed the filter like iron brass etc?Was thefluidreal dark what color was the fluid when you changed the filter?

Tiny

earl4

June, 12, 2012 AT 12:42 AM

No no debris and it was clean it was red

Tiny

saturntech9

June, 12, 2012 AT 3:27 AM

From your description it sounds like the transmission has pressure issue or bad clutch piston.

Tiny

earl4

June, 12, 2012 AT 3:35 AM

How cud I fix if or what do I have to do to fix it

Please login or register to post a reply.

Transmission Fluid Replacement Mercedes Benz
Transmission Service Toyota Tacoma
Transmission Service Ford Super Duty F-250
Transmission Drain and Refill Kia Sportage
Automatic Transmission Service
Transmission Speed Sensor Replacement Honda