Mechanics

93 - ALL WELL - THE ENGINE CRANKS BUT IT WONT START

1993 Toyota Corolla

Hi,

I drive a Corolla 1.6 - 1993, 4afe engine with approx 200K kms on the meter.

It was running absolutely fine!
I drove it over the weekend - it was fine. I drove it to work for 2 days - it was fine. I drove it to work the 3rd day, when I came back after work - it wouldn't start!

The battery is good - headlights, radio, key less entry all work. I can turn it to START and the engine cranks for as long as I want and as many times. The " Check Engine" light is off - still I jumpered the E1 and TE1 to check any codes - but none retrieved. But it just wont start!

I had the same problem 2-3 months back - when it would crank properly but would not start. Then, I towed it to the garage who checked every thing to be okay; yet asked me to change the alternator, the spark plugs and then temporarily replaced the ECM also - but nothing helped. Later I put my ECM back and the car started running.

This worked for 2-3 months and now again the same problem.
Avatar
Lecancy
June 7, 2007.




You need to check for spark and fuel comeback with the missing one. Also check the EFI relay, EFI and Ignition fuses.

At the battery pin on the check connector do you have battery voltage.
AD

Tiny
Rasmataz
Jun 7, 2007.
Hello Rasmataz - thanks for the response and advice.

The battery shows a green indicator - so that is fine.

I read something from the previous posts and tried it on my car. I removed the battery terminal for a while and then plugged it back on. This is said to reset the ECM memory. After connecting the battery back the car switched on, on the first crank. But it only lasted like a minute or so and then the engine turned off.

Tiny
Lecancy
Jun 8, 2007.
Check the fuel pressure with a gauge not the thumb or eyeball method. Comeback with the results

Tiny
Rasmataz
Jun 8, 2007.

AD