Mechanics

SPEED SENSOR PROBLEM?

1999 Saturn SL2

Transmission problem
1999 Saturn SL2 4 cyl Front Wheel Drive Automatic 234000 miles

I just bought a 99 saturn SL2 1.9L this car runs real good but while drivig it, I noticed that the check engine light was on and the RPM's were going up and down and the speedometer does not work. I had the codes pulled at a local auto parts store and they said it was the speed sensor. I replaced the speed senor and the the vehicle is still doing the same thing. I think I replaced the output sensor in the front of the transmission by the srew on transmission filter. Does this vehicle have an output and a input filter and if so where is the other sensor located? Any suggestions?
Avatar
Bernard 2k10
September 26, 2010.



The sensor by the transmission filter is the input one. The output sensor is by the drivers axle where it come's out of the transmission. What are the code number's you are getting?

Saturntech9
Sep 26, 2010.
Ok, The codes are PO722 (speed sensor low input) and PO522 (Oil pressure sensor circut condition) might be affected by the engine speed or possible oil pressure switch/sensor defective.
I changed the oil/oil filter and the transmission filter when I got the car.

Tiny
Bernard 2k10
Sep 26, 2010.


http://www.2carpros.com/forum/automotive_pictures/416332_1999_SL2_code_P0722_1.jpg


I couldn't find any code P0522 listed for your car i would double check and make sure what the actual trouble code was.I also emailed you the trouble tree for P0722.

Saturntech9
Sep 26, 2010.
Thanks for your input, I will try your recomendation.

Tiny
Bernard 2k10
Sep 27, 2010.