Mechanics

CAR WONT START

1998 Saturn SL2

1998 Saturn SL2 4 cyl

My car will turn over and hit every now and then but will not bust off completely. I have checked the spark and it is getting spark. I have taken the fuel filter loose and checked the fuel pump and it is shooting gas when I turn on the ignition. I can blow through the fuel filter just fine so I dont think it is clogged up. Any suggestions on what might be wrong?
Avatar
Mrkbruce
January 19, 2010.



Sounds like u have a bad coolant temp sensor try holding the gas pedal all the way to the floor while ur cranking it see if it starts. After u try that unplug the temp sensor see if the connector is corroded if it is then u will have to clean or replace the connector. It unplugs by squeesing the connector. There is two wires going to it a yellow wire and a black wire. Its screwed into ur head below where the upper radiator hose goes on. Becareful u will loose coolant make sure the engine is cold. The sensor is under 20 if u replace it make sure u get a brass tipped one the plastic tip ones crack and corrod the connectors.U could even take out the old sensor and see if its cracked. Let me know what u find.

Saturntech9
Jan 19, 2010.
That fixed the problem. I replaced it this morning and it is working just fine. Thanks again for your information. I really appreciate it!

Tiny
Mrkbruce
Jan 20, 2010.
Glad u got it fixed and I could help u out with ur problem. If u have anymore questions feel free to post them. Also thanks for using 2carpros.

Saturntech9
Jan 21, 2010.