Mechanics

STARTS UP ROUGH

1996 Saturn L200

Engine Performance problem
1996 Saturn L200 4 cyl Four Wheel Drive Automatic 165000 miles

My 96 saturn recently been starting up rough first time was not bad I did notice the ac was on it stopped after and today I started it and it was rough I did turn on the ac right away though but I had to press on the gas a few times then went back to normal. Please help out
Avatar
Mandibabe
June 9, 2010.




So when the car start's up rough do you get smoke out the tail pipe does it seem like it's flooding when starting?Also you said you have a 1996 L200 they didn't make te L model till 2000. So can I get the correct year and model so I can give you the correct information on your car.

Saturntech9
Jun 9, 2010.
It's a 96 SL2 and no, no smoke or anything comes out that I know of

Tiny
Mandibabe
Jun 9, 2010.


http://www.2carpros.com/forum/automotive_pictures/416332_2001_coolant_temp_sensor_8.jpg


I would try replacing the coolant temp sensor that is the most likely cause of what's going on with your car.Real common for them to go bad on your car they screw right into your head i posted a diagram of where it is.Make sure you get a brass tipped one the plastic tipped one's crack.Also make sure you inspect the connector going it if it's corroded replace it as well.Make sure your engine is cold when changing it and you will loose coolant.Let me know how it goes.

Saturntech9
Jun 9, 2010.
The picture is to small to tell
AD

Tiny
Mandibabe
Jun 9, 2010.
I emailed it to your personal email it say's 2001 sl2 but your's is in the same place. Let me know how it goes.

Saturntech9
Jun 10, 2010.

AD