Mechanics

SILVER SPUR STARTING PROBLEMS

Rolls Royce Rolls Royce

I have a silver spur III 1995 model done 75000 km, it has a very strange problem three out of ten times the car refuses to start after I have used the car and the engine is warm, and when this happens I can smell a lot of unburnt fuel from the exhaust and the car refuses to start, if I leave the car for 5 to 6 hours she starts in just a crank.I have also noticed that my car normally runs rich.
I did a experiment when the car died on me the last time, I pulled out the fuel pump relay and tried to start the car it took a few cranks but she started giving out a lot of black smoke.
I live in India and have no access to a service center or dealer and till date managed to look after the car with help and advice from people over the net.I would be highly grateful if someone could advice me as to where I should start looking for the problem
AD
Avatar
Zain bilgrami
August 11, 2007.



1. DON'T start poking around the HT circuit with screwdrivers, a dangerous activity. The ignition is ok or the car would not run at all.

Your symptoms indicate over fuelling, it won't start when warm because it seem to be treating the engine as cold. The most likely culprit is the injection system coolant water temperature sensor. This is a Bosch part and none too dependable, but not expensive, $20 or so, and easily changed. Try changing it for a new one. Hope this helps. FW
AD

Tiny
Wraith
Aug 12, 2007.
Thank you for the feedback would you be able to tell me where tis sensor is located in the car

Tiny
Zain bilgrami
Aug 13, 2007.
Thanks mate I think I have managed to solve the problem, I had the wiring loom to the thermostst body changed in doing so the connectors for two sensors seem to be interchanged I reversed them and She does not seem to be running rich HOPE It W : ) ORKS interchanged

Thank you for the feedback would you be able to tell me where tis sensor is located in the car[/quote: ab2dcc89fc]

Tiny
Zain bilgrami
Aug 14, 2007.

AD