Mechanics

INDICATOR LIGHTS

1988 Mercury Tracer

1988 Mercury Tracer, 4 door hatchback, 130,000 miles, 1.6L

Four dash lights are on but the things they indicate are working fine.

Low Fuel - Car has a half a tank of gas according to the gas gauge
Low Washer Fluid - Windshield washers work fine and plently of fluid
Battery - Car starts fine and gauge indicates it is charging
Brake - Brakes work fine and brake lights are working

Any ideas on what would cause these lights to come on when all the systems they indicate are working properly?

We checked the manual and it looks like all of these run of different fuses.

Any clues?
Avatar
AsecretK
July 30, 2007.



Try resetting the ecm. Disconnect the negative side of the battery for a couple of minutes. Reconnect it then drive the car. Some cars have to be driven about 50 miles before the computer will re set itself

M_H_RITZEL
Jul 30, 2007.
We did this and no change. Could it be the ECM itself?

Tiny
AsecretK
Aug 1, 2007.
Take the car to a garage and have them check the ecm, it costs a bit but it will tell you if the ecm is bad or the location of what is wrong

M_H_RITZEL
Aug 9, 2007.
Actually what you suggested worked. We did disconnect the battery for about 15 - 20 minutes and reconnected and nothing happened.

We got 2 miiles down the road on our way to Advance Auto to have them check the alternator and the lights went off and have remained off.

Thanks so much for your help!

I tried to reply before and leave stars but I could not figure out how to do it.

Thanks Again!

Tiny
AsecretK
Aug 10, 2007.