Mechanics

QUESTION BLACK SMOKE AND POWER LOSS AROUND

1995 Isuzu Rodeo

Engine problem
1995 Isuzu Rodeo Question 6 cyl Four Wheel Drive Automatic 112000 miles

Hello,

My 95 Isuzu Rodeo puts out black smoke and loses power when I accelerate to around 50 mph. The check engine light comes on some times, but if I rev up the engine, it will go off and run better.

Any ideas what might be the problem?
Avatar
Campbellot
January 6, 2008.



Hello !!

your engine its running "to rich"

start retrieving the "codes" and come back with the results to start the troubleshooting!

here`s how:

http://www.2carpros.com/dia/index.htm

Good Luck!

Tiny
Fisherman
Jan 6, 2008.
[quote=" fisherman" ]

Thanks for your reply, but I looked at the info for getting codes and it seems that the equipment for that is only for 1996 and newer; mine is a 1995. Can I still get the codes?

Tiny
Campbellot
Jan 6, 2008.
Hello !

Some vehicles start with the OBD II port on 1995
Check your car if it is equiped with the port

Should be located under the steering wheel.

Let me know if has it.

Tiny
Fisherman
Jan 6, 2008.
Hello !
Here is how to retrieve the codes and the codes:


http://www.2carpros.com/forum/automotive_pictures/576_rodeo_95_1.jpg




http://www.2carpros.com/forum/automotive_pictures/576_rodeo_951_1.jpg




http://www.2carpros.com/forum/automotive_pictures/576_rodeo_952_1.jpg




http://www.2carpros.com/forum/automotive_pictures/576_rodeo_953_1.jpg



Let Me know on the codes you get!

good Luck!

Tiny
Fisherman
Jan 6, 2008.