Mechanics

MY S10 IS PLAYING TRICKS ON ME???????????????

2010 Chevrolet S-10

I have a 2000 s10 zr2 with a 4.3L TBI....5-speed
i have been having some weird problems with it...My truck won't start right away,after it sits for a while.. If i crank it about 5 times it will start and willl idle fine.. I have noticed that the truck kind of boggs out , but only in 3rd and 4th gear (wreid)... My fuel pump went on me about 2 months ago, i don't even know, if that has anything to do with my problem?????
-I have changed the fuel filter
-I have checked for leaks and any damaged fuel lines
-I do hear the fuel pump when it doesn't start
-I Got a scan on the truck (nothing)
-I'm getting spark
-I'm getting fuel right up to the throttle body
-I have even put one of those fuel injector cleaners in

Could it be a faulty fuel pump or maybe fuel pressure regulator or maybe plugs, wires or bad injectors??????? but i thought if a fuel pump goes it dosn't work completly

As u can see i don't know what to do, so if someone out there can help , that would be great!!!!!!!!!
Thanx

I don't know what to do


http://www.2carpros.com/forum/automotive_pictures/87382_johns_toys_001_1.jpg

AD
Avatar
Johnmoura
August 3, 2007.




I am suspicious of the pump or the fuel injector spider assy. IT sounds like there is drainback of fuel into the tank. Try cycling the key when you think the problem is going to happen. That is, turn the key to the on position but not cranking and let the pump energize the line. Turn it back off for a second and then back on again. Do this 3 or four times, then crank it. If it starts right away, then you need to use a fuel pressure gauge and watch how well the pressure is held. IF it drops when the gauge is hooked up at the fuel rail, then you need to hook the gauge up at the filter area and re-check the bleed down to see if the pump is not holding pressure of the injector spider is allowing pressure loss.



AD