Mechanics

BAD ALTERNATOR LED TO TRANSMISSION TROUBLE.

1998 Toyota 4Runner • 200,000 miles

I was driving at night when my car battery died and the vehicle stalled. I replaced it with another fully charged battery and it started right up, but now the car will shift but not go into gear. When I shift back to park, there is a whirring/ grinding noise. The car will drive when put into 4WD but the back tires lock up. Are these two events coincidence?
Avatar
F_pank
November 1, 2013.




Wow, that doesn't seem like a coincidence. Have you tried disconnecting the battery and then reconnecting it? Has the check engine or any light come on? Can you explain what you mean by it will shift, but won't go into gear? I'm a little confused on that one. If it is shifting, it has to go into gear. And, what causes the rear tires to lock up?

I have tried disconnecting and reconnecting the battery. I am fairly certain the alternator is shot due to the battery drain, but I do not know how that would affect the transmission. No check engine light, but the A/T P light comes on when the 4WD is in neutral. The shifter will move (not the brake light safety switch), but the car will not go into reverse or drive. I can only get the car to move when the 4WD is engaged, but one or both the rear wheels feel like they are dragging. However in 4WD reverse the rear wheels move freely.

Tiny
F_pank
Nov 1, 2013.
Okay, we need to start at our power source, the battery. Make sure it is fully charged first. Then check to see if the alternator is charging the system properly. Directions on how to check these things and videos are on our homepage under the DIY section. Since you question the alt, it makes me question the power supply to the different sensors on the transfer case. Also, I need to know if you have the electric shift 4wd or a manual shift 4wd. If it is electric, we need to check to make sure the actuator on the transfer case is getting power when you shift to 2wd. That could be an issue as well as the actuator itself.

Let me know what you find. (And sorry, it sounds like I'm pointing you in the wrong direction, but if there is a power supply issue, all kinds of crazy things can happen.)

Let me know.
AD


AD