Mechanics

ENGINE RUNNING WHEN OFF, CAR DIED. WHAT HAPPENED?

2008 Dodge Avenger • 58,000 miles

I have a 2008 dodge avenger. I was in idle for about 10min. When I went to reverse, the engine sounded really rough, like it was running really hard. I shut it off, turned it back on and it started hard. I parked, went to shut it off and the engine would not stop running but it did not sound normal. It was running really hard. I tried multiple times to start it back up but the engine would not turn over. It finally just died. I tried again about 3min later and it was as if nothing happened. The car started fine. I since then have tried starting it about 6-10 times and there seem to be no issues. Please help!
Avatar
Dani3586
November 16, 2011.



Next time it refuses to start don't wait for it to make up its mind-do below immediately to determine if its fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, cap and rotor, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing

Rasmataz
Nov 16, 2011.