Mechanics

CHEVY

2006 Chevrolet SSR • 100,000 miles

I installed a new throttle body and gasket last night on my dads Chevy SSR. The last one I was having problems out of it. I ran it last night had all 400hp it was fast almost like new again. It was a cool night. I shut it off a bunch of times last night and it started. I went to start it at 5: 15pm today and it would not start. Here are the codes I got p0443 p1516 N/A another N/A p0443 and p0689. The N/A codde will not erase from the system the p0443 is another hard one to erase. Please help me. Thanks.
Avatar
Sean03
June 27, 2012.




Stop erasing as it does nothing. The tech checking the car needs the freeze frame data to see the readings when the failure happened.

Roy
AD

ASEMaster6371
Jun 28, 2012.
It is weird. The car wont start if the weather is hot outside. I started it tonight started fine no problems. It shuts off fine and starts right back up. Their is also no trouble codes at all. Could the canister purge valve solenoid be causing this. Also why would the P1516 CHEVROLET - Throttle Actuator Control Module Throttle Actuator Position Performance come on. I just replaced the throttle body and the gasket.I would rather not have to take it to the dealer if I dont have to. Thanks.

Tiny
Sean03
Jun 28, 2012.
Did you replace replace the pedal sensor/module as well?

Roy

ASEMaster6371
Jun 28, 2012.
No I didn't was I suppose to.

Tiny
Sean03
Jun 28, 2012.
Thats because you are not a tech. In most cases, the throttle body and pedal sensors are replaced together.

Roy

ASEMaster6371
Jun 28, 2012.
Would all the symptoms that I am having be related to that. I talked to someone on here and told him I was going to replace the throttle body because I was having problems. He didn't tell me I need to change that to. Thanks.

Tiny
Sean03
Jun 28, 2012.
Good luck

ASEMaster6371
Jun 28, 2012.

AD