Mechanics

WE HAVE LS .140036 KM.WHEN I TURN ON A/C SWITCH THE BLOWER MOTOR IS WORKING.BUT THE A/C COMPRESSOR IS NOT WORKING.NO CURRENT GOING TO A/C COMPRESSOR.REFRIGERANT IS AT FULL LEVEL.I CHECKED ALL THE FUSES AND RELAYS ARE ALL OK.ANY SUGGESTION,PLS.

2006 Chevrolet Caprice • 140,036 miles

Caprice 2006 140036 km.A/c compressor not working. All fuses and relays are all ok. When I turn on the a/c switch inside blower is working but no current going to a/c compressor. Refrigerant is at charging level, ok. What might be the trouble pls.
Avatar
Asventu
March 3, 2012.



If you're sure is has over 50PSI of static pressure, then you have an electrical issue that will have to be tracked down using a wiring diagram and test light.

I tried to supply you with a wiring diagram but I don't even see a Caprice being made in 2006 here in the US.

Wrenchtech
Mar 3, 2012.
Sir, I just want to make some clarification regarding my question about caprice a/c not working. The year model written is oct.2006. But when I checked the owner's manual it is model 2007. It was assembled by GM australia. Yes sir, the static pressure is 70 psi. The a/c control switch are all push button. Air vent inside are all working good. The blower low, medium and hi speed are all working good. The only problem is no current going to a/c compressor.

Tiny
Asventu
Mar 3, 2012.
Like I said, you need to troubleshoot the electrical circuit for the compressor and we don't have that car so I can't give you wiring a diagram.

Wrenchtech
Mar 3, 2012.