Mechanics

COMPUTER DIAG PORT

2005 Saturn Vue • 112,000 miles

Cant pull the codes out when I hook up the scan tool it shoes to check the key is on and hooked up properly, everthing is hooked up properly and I know it has a code the cel is on, could it be a fuse blown or am I having another problem
Avatar
Dennisgwagner
June 5, 2012.



Check to see if you are getting power to the aldl and ground. The key has to be on to read the codes. Check fuses underhood and under dash

Hmac300
Jun 5, 2012.
Just to add to this one does your code reader power up off the obd2 connector?When you plug it into the obd2 connector does it automaticaily turn on?

Saturntech9
Jun 5, 2012.
Yes it does get power from the connector port, and it does come on just cant retrive the codes from the port

Tiny
Dennisgwagner
Jun 5, 2012.
I would make sure the scan tool works on other cars before going too far in checking wires etc.I have very rarely seen one of those vues that you couldnt talk to the ecm that would start. Also check and make sure there are no broken wires going to the obd2 connector.

Saturntech9
Jun 5, 2012.
I tried it on our honda and it will connect to that ecm, I dont see any broken wires could it be the diag I am using is outdated?

Tiny
Dennisgwagner
Jun 9, 2012.
If it works on other cars it should work on yours. Check to see if you are getting power to the aldl andground. A test light can do that.

Hmac300
Jun 9, 2012.
I checked the signal ground and chassis ground and the battery power with a volt meter and all are good

Tiny
Dennisgwagner
Jun 9, 2012.
Then you'l have to check the rest of the connections and wires

Hmac300
Jun 9, 2012.