Mechanics

CAR WON'T START BUT CRANKS

2004 Kia Amanti • 120,000 miles

My Amanti wont start it cranks no start. I have check plugs change fuel pump, check fuel pump relay, check coils good spark very strong. It would try to start but it would die out. If I squirt a little starting fluid into throttle body it would start up and run-until it burns off. This only happen after I stop and put gas in my car it was running fine before. I stop turn car off put in gas try to start very hard engine running with now power.I started to drive home and it got better and run nice after a few minutes. I parked in the driveway and it would not start for three days now. Run code check it is giving me a code for the MAF sensor could this prevent the car from starting? I thought it was the CPS but no codes for that can you shed some light. Cpttrevor
Avatar
CptTrevor
October 5, 2012.



I thought we were done with the tps codes. What are the exact code numbers you have not code descriptions?

Saturntech9
Oct 11, 2012.
I am still working on getting this car started I have checked the fuel injectors. I removed them and check to see if the injectors were spraying and they are. I have spark at the plugs I have change the camshaft position sensor. Car cranks but wont start if I put starter fluid in throttle body car starts right up and runs very good for short while.I have run a scan for codes no codes present in vehicle. Can you help Cpttrevor

Tiny
CptTrevor
Oct 18, 2012.
What is your actual fuel pressure?

Saturntech9
Oct 19, 2012.
About 48 with disconnected from fuel pressure reg and around 35 0r 38 with line connected. Cpttrevor

Tiny
CptTrevor
Oct 20, 2012.
Sounds like the injectors arent pulsing is the security light on solid or flashing?

Saturntech9
Oct 20, 2012.
The Injectors are pulsating according to the light flashing and firing in the correct sequential order. Cpttrevor

Tiny
CptTrevor
Oct 20, 2012.
Then its getting fuel so doesnt make sense why it will run when you prime it.

Saturntech9
Oct 20, 2012.
Like I have stated why? Can the throttle system like the motor APS the ETS motor and the ETS control unit be bad and not giving the signal to the throttle to allow the car to start? Cpttrevor

Tiny
CptTrevor
Oct 21, 2012.
I know it goes into limp mode when a failure is detected so it limits throttle opening greatly. If its like a gm car if it detects that failure next key cycle it wont start. The kia repair info I have isnt ver very detailed. Let me see if there is a another moderator on here that knows these kias well.

Saturntech9
Oct 23, 2012.
On the scan tool does the tps sensor show.3-1.0 volts without touching the gas pedal?The while holding it to the floor it should read 4.2-4.8 volts?

Saturntech9
Oct 23, 2012.
Page 3 of 5