Mechanics

LOUD SQUEALING AND EXCESSIVE COOLANT PRESSURE STARTS AFTER MUCH EFFORT, RUNS ROUGH AND AT HIGH RPMS, THEN DIES.

2003 Mazda Protege • 80,000 miles

The squealing sound is coming from the throttle body area (not specifically the throttle body). I just replaced the head gasket, head bolts, and all gaskets nessesary when reassembling. Deck and head surfaces were withing flatness specifications. Timing was reset to factory. Ignition is a little weak but sufficient and fuel delivery is good. This problem completely baffles me and is disappointing with the experience I have and a run performance certification. I know its difficult to diagnosis without seeing the car, but all help is appreciated.
Avatar
Rlc3isme
September 7, 2012.



First you need to do is to locate the source of the noise. Throttle body can only be air noise which would squeal if an air passage has a leak or there are restrictions to it.

Ensure the cooling system has been bled of air trapped in system and if the high pressure continues, it would mean the head job has a problem somewhere.

If the reason for replacing the head gasket was due to overheating, the head seems to be the one at fault, or at least it is related to it.

Were the valve clearances checked/adjusted?

KHLow2008
Sep 7, 2012.
Thank you for the quick response. The original problem was coolant leakage into cylinder but once it warms up it went away. Also cylinder to cylinder leakage. Valve clearances and actuation was fine when the head was off. Definitely did not check for the air in the coolant system, too busy over thinking everything I guess. Now that I think about it the throttle body gasket had slits covering (maybe) vacuum passages.

Tiny
Rlc3isme
Sep 7, 2012.
Ok, go through them and see what you come up with.

KHLow2008
Sep 7, 2012.
Coolant reservoir hose is completely clogged.

Tiny
Rlc3isme
Sep 7, 2012.
That can cause the high pressure. Excessive air noise can be due to high idling speed due to the IAC opened too much caused by coolant faults.

KHLow2008
Sep 7, 2012.
Ok unclogged the reservoir hose. Fixed the problem but need a new radiator cap I had to put it on half way to allow it to flow to reservoir, because it is stuck closed. The car is still dying and throwing a code for the MAF and o2 sensors.

Tiny
Rlc3isme
Sep 7, 2012.
Check for vacuum leakages between throttle body and MAF. Seems the squealing noise has something to do with it.

KHLow2008
Sep 7, 2012.
Alright. Thank you for all of your help!

Tiny
Rlc3isme
Sep 7, 2012.
You're welcome.

KHLow2008
Sep 7, 2012.