Mechanics

ENGINE STUMBLES AND DIES

2002 Ford Taurus • 3.0L V6 FWD Automatic • 102,000 miles

Engine stumbles and dies when throttle is opened to +1500 rpm then closed quickly in Park or neural.
Replaced plugs, wires, air & fuel filters, fuel pump. Recently passed CA smog certification with low emissions readings.
Avatar
LarryW64
July 1, 2014.




What brand of plugs did you use? Should be Motorcraft only NEVER BOSCH.

First eliminate all vacuum or air leaks in the system. You may have a bad IAC ( idle air control) but try cleaning the throttle body first. Remove the intake snorkel, have someone hold the throttle wide open for you and scrub the back side of the throttle plate and surrounding bore with an old tooth brush and some carb cleaner. Be sure to spray some into the small holes next to the throttle plate. That should help stabilize the idle. If it still has a problem, replace the IAC.

Wrenchtech
Jul 1, 2014.
Installed Motorcraft plugs, throttle body is black inside. Will clean. Is there any test I can do for the IAC?

Thanks,

Larry

Tiny
LarryW64
Jul 1, 2014.
Not really. It's probably just not responding fast enough.

Wrenchtech
Jul 1, 2014.
Try cleaning throttle plate on both sides and iac hole with choke cleaner.

Hmac300
Jul 1, 2014.
Thanks Hmac300, I'll see if that works.

Tiny
LarryW64
Jul 1, 2014.
Hi Wrenchtech, Then I replace the IAC? I think I found a hose going the transition piece from the throttle body to the air filter that's not real snug.
Thanks for your help, hope this works.
AD

Tiny
LarryW64
Jul 1, 2014.
Replaced the IAC and a vacuum line. Engine seems to be operating normal now. Thanks for your help.

Tiny
LarryW64
Jul 8, 2014.
You're welcome.

Wrenchtech
Jul 8, 2014.
New issue after replacing the IAC, went for a test drive. The engine is idling at 1500 rpm's in drive after driving about 1/8 mile, engine at operating temp. I put it in park and idle went to 2000 rpm until rapid throttle open/close. Then it dropped to 800 rpm.

Any suggestions? I disconnected the battery but haven't reconnected it yet.

Thanks,
Larry

Tiny
LarryW64
Jul 8, 2014.
You can try that with the battery but it sounds like you may have gotten a defective unit.

Wrenchtech
Jul 8, 2014.

AD