Mechanics

CAR RANDOMLY DOESN'T START

2001 Saturn L300 • 144,000 miles

Hi, my L300 has a few issues, but the most problematic at this point is that it won't start. Some days it will, some days it won't. And jyou can't jump it off. It sounds like it's cranking and starts to catch but then doesn't. I had a problem like this with my lawnmower, and it was bad gas. But this car doesn't have bad gas, I don't think. When it will start, it runs as it always does. We had it to the dealer, and they think it's the BCM because of some other issues that I have with it, such as the door locks sporadically not working, the radio sporadically not working, etc. It is not throwing any codes. Another mechanic doesn't think the BCM would cause it not to start and that it may be the ECM. Yet another thinks that it might simply be a faulty ignition and a very simple fix. The other thing that it has done for a few years now is that it has what I would call a performance issue. In low cruise speed, such as in a neighborhood, the car kind of sporadically loses power (not one big drop and engine boggle) just sort of like misfiring, but that's not it exactly either. It you stomp the gas, it will go. And every rare now and then I smell unburned fuel. But no one can tell me what is causing this. The transmission was just fully redone because it was shifting hard, and this is fine now. I really want to sell this car, but I can't in good conscience sell it when I know it's going to be a headache for someone to fix! Can you help? The fuel filter is good, the throttle body control module and gas tank were replaced a couple of years ago becuase I was smelling a lot of unburned fuel, and they told me I had a tank leak. But right after that, maybe, is when the performance issue started. Thanks for listening. I'm frustrated.
Kyra
AD
Avatar
Kcatlady
March 29, 2012.



So when the car cranks and wont start is the security light on solid or flashing?Also when it wont start are the power door locks inop keyless entry inop fuel gauge or temp gauge inop inside lights inop car wont come out of park etc?

Saturntech9
Mar 29, 2012.
Yes a a bad bcm will cause it not to start?Its very common for those cars to have a bad bcm I have replaced a ton of those bcms because they were bad.

Saturntech9
Mar 29, 2012.
YES! I just tried to crank it, and the overhead light won't come on, the power locks won't work, the temp/fuel gagues won't shoot up, etc. And after the dash lights go off, the service light with the wrench lights up as well as the service engine soon light. But if it has started the service lights haven't been on.

Tiny
Kcatlady
Mar 29, 2012.
Can a bad BCM also contribue to the loss of performance issue I was describing? IF not, do you have any suggestions on that? I'm actually getting a glimmer of hope.

Tiny
Kcatlady
Mar 30, 2012.
Can I get a salvage BCM? I was told I had to get one that could be reprogrammed, and with matching numbers on the box. Not sure what exactly that means or where to find the numbers I need to match.

Tiny
Kcatlady
Mar 30, 2012.
Sorry, I missed the question about the security light. I'm not seeing a security light.

Tiny
Kcatlady
Mar 30, 2012.
It sounds just like a bad bcm for the starting concern i have replaced a lot of those for that issue.As far as a used bcm you cant do that because the bcm stores the cars mileage on that car.So the used bcm would make the cluster display the mileage of the car you got the used one from.Also i wouldnt trust a used bcm on that they have a really high failure rate.I would go with a new bcm they have to be programed from the dealer with the correct mileage options calibration file etc.I would of course have the bcm diagnosed before having it replaced because its hard to say for sure over the internet if its bad for sure.But it sure sounds like a bad one.If it needs a new one though it would probably be cheaper to buy one online.I would try http://www.rockauto.com and http://www.parts.com As far as your power loss i have never seen a bad one cause the engine to lose power.So when the engine loses power do you ever have to let up on the gas for the car to shift to the next higher gear?

Saturntech9
Mar 30, 2012.
No, it doesn't completely lose power light totally idling down or anything. It doesn't drop. It just doesn't accelerate smoothly. It acts like it isn't getting a consistent fuel flow, really, but nothing can be found wrong wtih the fuel system in any way. Fuel pressure is good, new fuel filter, new throttle body assembly. It just acts like a fuel problem. And at low cruise speed it drops in and out. Somewhat like surging but it's not surging like the accelerator is stuck or anything. ARGH. So hard to explain.

Tiny
Kcatlady
Mar 30, 2012.
They cleaned the fuel injectors, which helped very minimally for a few days, and then right back to the problem. I was wondering if the throttle body assembly that I had replaced was never a good one to begin with. But again, no codes.

Tiny
Kcatlady
Mar 30, 2012.
When they changed your throttle body assembly did they also change the connector to it?I would have changed both.
AD

Saturntech9
Mar 30, 2012.
Page 1 of 2

AD