Mechanics

MAZDA ETUDE SPARK PROBLEM

2000 Mazda Etude • 180,000 miles

I have no spark on the plugs I trced the wiring for open cercate and I checed the fuses none blown I dont know if it has a relay for the ecu controle
AD
Avatar
Francoispienaar
October 31, 2012.



Which engine do you have? Did you check for battery voltage to the coil packs? Are ther any trouble codes?

KHLow2008
Oct 31, 2012.
I went through the wiring again and I finded a blown fuse so it was por surch and now I have cuurent to the coilpack but still no spark on the spark plugs. On the plug that goes into the coil pack is three wires the one I see is earth and the other positive so than what is the middle wire for and how does it opperate

Tiny
Francoispienaar
Oct 31, 2012.
That should be for the Engine Computer to signal the coil to fire.
Did you check for trouble codes?
Which engine do you have?
Have you checked the crank sensor?
AD

KHLow2008
Oct 31, 2012.
It doesen show any codes on the cluster
it is the zm3 engine
i traced the middle wire and it goes to the ecu
now can it be that I can suspect the ecu
cause I have put other sensors on the cranck and cam sensors and I put even other coil packs on but still it just swing strongly with out spark
but I have contenuiaty/current to the coil packs
if I put a wire from the wire that goes to the ecu on the coil pack to the post of the battry it sent spark throuth to the spark plug but it doesnt start like that

Tiny
Francoispienaar
Nov 1, 2012.
If the crabk sensor is godd, the only problem causing the no spark wuld be the PCM. If you have immobilizer system ensure it is not armed.

KHLow2008
Nov 1, 2012.

AD