Mechanics

RANGE ROVER HEATER. HELP PLEASE.

2000 Land Rover Other • V8 AWD Automatic • 100,000 miles

Have a 2000 Range Rover HSE, with digital controls. When I activate the heat, whether auto or manual to the high position, I am getting heat through the vents, however the fan which blows the heat through the vents as you raise the temp. Is not kicking on. When I adjust the temp. Controls to a lower tempt. I.E. From HI to 70 degrees, I can feel the fluctuation in the temp drop however again the fan is not turning on. I've been given answers that it's the fan istelf which is broken, or something is clogged inside the fan, and or the motor to the fan is shot. I'm having a difficult time locating the fan and it's respective motor. If anyone could assist me with a possible diagnosis and the location of such I would greatly appreciate it.
AD


Avatar
Bouchardbarry
December 28, 2010.



This is all I could find, but it's behind the glove box. First check fuses 42 and 43. BLOWER MOTORS

Removal & Installation

1. Remove glove box assembly. Release 2 clips securing fascia harness to fascia frame. Remove
center screws from 4 scrivet fasteners securing driver's side lower closing panel. Release panel
for access to harness clip. Collect outer parts of fasteners from closing panel. Remove upper
fascia closing panel.
2. Release clip securing harness to fascia frame. Remove 2 bolts securing cruise control ECU
bracket to fascia frame and position bracket aside. Release SRS harness connector from
bracket and position harness aside. Disconnect connectors from blower motor. Remove 4
screws securing blower motor to casing. Remove motor and fan assembly. Do not stress fascia
harness. To install, reverse removal procedure.

Merlin2021
Dec 28, 2010.


AD