Mechanics

CHEVROLET SILVERADO FUSE PROBLEM

2000 Chevrolet Silverado • 120,000 miles

Sure you have never heard this one. Took engine out to remove/replace exhaust manifold bolts that had broken due to broken motor mounts. All went well and put engine back in and carefully reconnected all wires - really can't get them hooked wrong due to the different plugs and wire layout. Then the fun began, when hooking battery back up the ABS runs, the cruise light and high beam indicator light are on and all this with the key not in the ignition. Call me stupid but decided to try to start anyway and it cranks and even trys to start but doesn't keep running and then the horn starts to blow. You bound to be laughing by now. I have checked and rechecked every wire connection and all the grounds and can find nothing. Any ideas what is going on?
Avatar
Bniehues
February 9, 2013.



I would back track by taking apart connectors with the battery hooked up to see where the issue lies.

Also, did you trap any harness in anything like the bell housing area?

Roy

No pinched or trapped wires or unconnected wires. Pulled ABS fuse to stop it, pulled cruise fuse but light remains on. Tried headlights and they work fine and switch from high to low but high beam indicator never goes off. After pulled ABS fuse just turned key switch on without cranking and horn started blowing. This is nuts.

Tiny
Bniehues
Feb 9, 2013.
Do you have an alarm system?

Roy

No alarm.

Tiny
Bniehues
Feb 10, 2013.
Just realized put Chevrolet 2000 instead of 2004, was thinking of other pickup but don't think anything much different. Have gotten the problem isolated to traveling through the radio fuse. When pull radio fuse under hood the indicator lights go off on dash but still won't start and ABS still runs if replace the fuse. The radio also does Not work with the fuse in and key on, totally blank and think I hear a slight buzz in speakers. Just keeps on getting stranger.

Tiny
Bniehues
Feb 13, 2013.