Mechanics

READING CODES PO340 AND PO300

1998 Suzuki Sidekick • 15,300 miles

98 sidekick automatic 4x4 idle surges up and down when cold and levels off to a stall out after warm and runs rough and can not drive or it wont go fast enough.I replaced o2 sensors as it needed them for a good while, than the maf and after that a few days it started rough idle, my cat was not even a year old. Now I hear a rattle sound in it like something is bounceing around in it. When I rev the motor it revs good just wont idle right and in drive has no pick up just boggs. Thanks for any help you can spare. Mj
Avatar
Zuky
August 27, 2012.



Okay I just did a resistance on valve and it is 11 being in spec, I read voltage with key on, on the plug and it is only getting 10- 11 volts. I cleaned the valve and run a fused wire from battery to test valve and it opened and I could blow freely through it, does this mean Im not getting proper volts from pcm?

Tiny
Zuky
Sep 15, 2012.
After cleaning the IAC, what are your present issues?
You need not follow the troubleshooting to the dot. You stop when the problem is resolved.

KHLow2008
Sep 15, 2012.
Okay I need to know how many volts from the iac plug that plugs into iac is suposed to read? Im reading 9.33v and the iac is not openning at this voltage, But when I use a jumper wire from 12 v battery it opens.

Tiny
Zuky
Sep 15, 2012.
I also reinstalled the iac and started motor idle is still high and after warm up it idle come down to a stall out motor, I took a code reading and po505 is gone, but Im reading a po510

Tiny
Zuky
Sep 15, 2012.
You don't seem to be doing things correctly and instead of solving one problem, you created another.

P0510 is a fault with the TPS.

When cold the idle rpm would be high due to the cold start system.

KHLow2008
Sep 15, 2012.
How would u know or even say that when u just jumped on board with whats going on with crap car Im working on? Who are u anyway? I was dealing with saturntech9 and out of no where u appear! Its hard enough with one person and than switch to someone who doesnt know where Im at, at this point, This car has had a high idle from the begining, You never answered my question about how many volts is supposed to be comeing through the iac plug?

Tiny
Zuky
Sep 16, 2012.
The blue wire with a black tracer going to the iac should have battery voltage with the key in the run position?It gets power from the fuel injector power feed wires.

Saturntech9
Sep 16, 2012.
I had been following what you had been doing from start till now and knows what is going on.

Sorry for being nosey parker. Have a nice day since I am not welcomed here.

KHLow2008
Sep 16, 2012.
Okay this is to saturn9, Motor has come a long way from the start of all this the idle is still to high even when hot, the surgeing has stopped, there are no codes after I took it for a ride. But idle is not stable sometimes it will go so low it stalls motor

Tiny
Zuky
Sep 16, 2012.
One more thing Im not sure this iac is operateing properly. Trouble tree says to turn key in on position and blow through air tube to see if iac switch is open, It is not open cannot blow through tube.

Tiny
Zuky
Sep 16, 2012.
Page 5 of 7