Mechanics

BUICK REGAL RADIATOR PROBLEM

1996 Buick Regal • 10,100 miles

My buick regal has been stalling after a few miles and then will not start for about an hour, I was told that it was getting to hot, I changed the thermostat, temperature control sensor and throttle position sensor, ignition module and the coils, before I changed the coils the car did not show it getting hot by the guage on the dashboard however now it immediately goes to high after starting the car. It has a 3800 series 2 engine in it. Please help!
Thanks
Avatar
Conniefunkmaginnis
March 11, 2013.



Radiator partially plugged can be a cause, waterpump, and yes the thermostat, when you run the vehicle and you get to warm up temperature, turn off the engine, feel the upper radiator hose and make a comparision to the lower, if they are both cold you have a failed water pump, go to the radiator being careful from the fan incase it somehow start, feel the radiator is the bottom cold and the upper hot or extreme difference in temperature? The radiator is partially plugged, If one radiator is hot and the other is not go back and recheck the thermostat, or get another one installed. (New doesn't mean good) and does the cooling fan turn on at all?

Tiny
Randico
Mar 11, 2013.
When it doesn't restart, are you getting spark and fuel to the engine?

Yes it is gettin fuel and spark it acts like it wants to start runs real rough and jumpy then it dies out again

Tiny
Conniefunkmaginnis
Mar 11, 2013.
And the radiator hoses are both warm/hot nto the touch no difference. Someone suggested na fuel relay switch?

Tiny
Conniefunkmaginnis
Mar 11, 2013.
Also the fan on the right comes on intermittently and the left one I havent seen come on at all could that be the fan motor or a fuse?

Tiny
Conniefunkmaginnis
Mar 11, 2013.
Is the check engine light coming on?

Yes it came on after I installed the coils

Tiny
Conniefunkmaginnis
Mar 11, 2013.
What trouble codes were retrieved?