Mechanics

SECURITY LIKE STAYS ON WHEN RUNNING CAR, HOW DO I FIX

1995 Pontiac Firebird • 98,000 miles

I bought a 1995 firebird 3.4l automatic. I noticed the vats connection for the key was disconnected so I re-connected it but security lights on when running. No trouble starting and running car. I have read the horror stories about the vats system. The light start on continuously does not blink. The car starts weather the vats key cable connected or not same with light
Avatar
Mr_fxst
July 15, 2012.



I posted a trouble for you most of the time the wire to the key cylider breaks inside the insulation.


Saturntech9
Jul 15, 2012.
The car starts and runs fine took on small trips of 150 miles, if the vats cable was brake would not the car not start?


Tiny
Mr_fxst
Jul 15, 2012.
Depending on the break it could start I posted a trouble for your symptoms. ALso your theft module is to the right of your radio in the dash. Let me know what you find and we can go from there and I can also get you more info if needed.


Saturntech9
Jul 15, 2012.
I have the original key tumbler with wires cut, I have new one installed with the 2 wires in orange sleeve in place and with the same resister value. Now I have 4 keys that start the car. I dont believe it is in the keys or the wire. I will check the TDM thanx


Tiny
Mr_fxst
Jul 15, 2012.
Follow the trouble tree I posted lets go from there. Keep me posted.


Saturntech9
Jul 15, 2012.
I disconected the TDM. I let the car run for 5 minutes. The security stayed on and did not blink. The grounds are good as fasr as I could tell. How do I check what the resistance shout be at the TDM. Or how can I tell what it is looking for? I checked every fuse in car and they were good. The cable wires(2 white ones) measured good with the key in. There is a 5 prong connector by the headlight switch and has nothing plugged into it. Looks like there was though. Here is a pic of it. What is it for


Tiny
Mr_fxst
Jul 16, 2012.
It says to just unplug the theft module and turn the key to the run position then see if the light is on?If it is then there is short somewhere to the security light. Are you sure you unplugged the correct module?Also are sure someone didnt bypass that module at some point?


Saturntech9
Jul 16, 2012.
The tdm was behind the glove box and I checked it both with the car on and off. Still security light on. Yes I think that someone has modified it but where? The white wires are not cut and shows right resistance, tdm looks like it was never touched, the car starts and runs with wite wires attached or disconnected. Car does run a little ruff so I check the injector and they looked fine. The plugs I have to replace.


Tiny
Mr_fxst
Jul 16, 2012.
Theres a theft deterrent relay mounted to the right side of the sir bracket see if the wires to it have been cut/tapped into etc.


Saturntech9
Jul 16, 2012.
What is a sir bracket? And where is it


Tiny
Mr_fxst
Jul 17, 2012.
Page 1 of 4