Mechanics

SECURITY LIKE STAYS ON WHEN RUNNING CAR, HOW DO I FIX

1995 Pontiac Firebird • 98,000 miles

I bought a 1995 firebird 3.4l automatic. I noticed the vats connection for the key was disconnected so I re-connected it but security lights on when running. No trouble starting and running car. I have read the horror stories about the vats system. The light start on continuously does not blink. The car starts weather the vats key cable connected or not same with light
Avatar
Mr_fxst
July 15, 2012.



To the right of the glove box. Also the sir bracket is the support for the air bag.

Saturntech9
Jul 17, 2012.
I removed the relay and all 5 wires are attached and untapered with. I traced the wires as far as I could and looked like they have not been tampered with

Tiny
Mr_fxst
Jul 17, 2012.
Does it start with the relay unplugged?

Saturntech9
Jul 17, 2012.
There should be a brown wire a yellow wire with a black stripe a yellow wire and a purple wire going to it.

Saturntech9
Jul 17, 2012.
Yes those are colors and car did not start

Tiny
Mr_fxst
Jul 17, 2012.
It has to be modified somewhere because the theft module supplies the ground trigger for the theft relay. If the theft module is unplugged then the relay wont get the ground for the starter to work.

Saturntech9
Jul 17, 2012.
Yes I am sure of that but if not at relay, wires from key, at TDM or at the injectors where else could it be?

Tiny
Mr_fxst
Jul 17, 2012.
If the starter works with the theft module unplugged and the starter is working the relay is getting ground trigger from somewhere.

Saturntech9
Jul 17, 2012.
The looks like a dealer problem then. Looks like it is beyond you and i. Thanks anyway

Tiny
Mr_fxst
Jul 17, 2012.
Alright if you want to call it quits then please know let me know what you find.

Saturntech9
Jul 17, 2012.
Page 2 of 4