Mechanics

FORD 500 SENSOR PROBLEM

1995 Ford 500 • V8 4WD Automatic • 200,000 miles

I have a 1995 ford 150 4x4 auto extra cab auto. Where is the speed sensor located on the trans? My speedometer doesnt work and my truck shifts hard going to first to second. My mechanic said it was the instrument cluster. I replaced it but not the problem, Thanks
Avatar
Mrm
March 8, 2011.



Left rear of trans

Docfixit
Mar 8, 2011.
Thanks is it on the shifter?

Tiny
Mrm
Mar 8, 2011.
NO further back on tail shaft

Docfixit
Mar 9, 2011.
The speed sensor on the 1995 ford 150 auto is on the rear axle on the top. The book says it is on the trans. The speed sensor didnt fix my problem. My speedometer still does not work. And still shifts hard. The only way it will run is with the center wireing plug pulled from the cluster.I put another cluster in and it didnt help. Any Ideas?Thanks MITCH

Tiny
Mrm
Mar 11, 2011.
No sensor on diff is for ABS brakes Output Speed Sensor is on trans two wire connector. Need engine size and trans type

Docfixit
Mar 11, 2011.
That must be why speedometer still does not work. It is a 5.8 and e40d? Is that a c 8? It is 1995 150 4x4. I just see wireing going to the top of shifter. On the trans. I cant wait to fix the problem.[ To find out what it is ] Thanks for helping me. This might help. Everything seemed fine until I put it in Four wheel drive. Thats when everything happen. Speedometer started jumping all over, Truck was acting like something was locking up and had to rev up the rpms to get moving. To keep from driving, Once driving seem ok as long as moving. Thanks again

Tiny
Mrm
Mar 11, 2011.
O.K. E40D/5.8L speed input from diff sensor signal goes to PCM and Programable speed odometer module on instrument cluster if faulty will cause harsh shift and down sfift unexpected. Maybe what is the problem only way to confirm need scan diagnostics of trans.

Docfixit
Mar 11, 2011.
Thanks. I got a different one from the wrecking yard but it had the same results. What do you drink? The good thing is I can take the cluster out in 5 min. I am going to get a different one and try it. I will let you know. Thanks again MITCH

Tiny
Mrm
Mar 11, 2011.
Good let me know this is an interesting one

Docfixit
Mar 11, 2011.
Hello From Ca. My problem is fixed. This is too much. It was my cluster after all. After getting one from the junk yard, It didnt work. So I found another one and it worked. What a differance. Speedo works, lite on the over drive is off and trans is shifting great. All in all it was a great learning experience. All for less than 20 dollars. Thanks Docfixit, MITCH

Tiny
Mrm
Mar 21, 2011.
Page 1 of 2