Mechanics

CAR RUNNING POORLY

1993 Mitsubishi Eclipse

Engine Performance problem
1993 Mitsubishi Eclipse 4 cyl All Wheel Drive Manual 95000 miles

my car check engine light came on said o2 sensor upstream malfunction but before I changed it the car would run fine until it heated up then it would idle funny once the engine warmed and die on me every time I came to a complete stop it a 5speed manual. Now heres the weird part I changed the o2 sensor but with every new sensor I put in the car either wont start or runs like miss firing and idiling poorly cant even drive it why with every sensor I try it runs like worse but when I put the bad sensor in it runs fine before it warms up
AD
Avatar
Marquis.peay
October 24, 2010.



Check and test the idle speed controller, Mass air flow and throttle position sensor-also clean out the EGR and PCV valves

Rasmataz
Oct 24, 2010.
Well my question is how come when I put the old o2 sensor in the one thats giving me the check engine light it satrts up perfectly and runs but it does idle a little high but stil runs and drives until engine warms up then it starts to shut off when I come to a complete stop
AD

Tiny
Marquis.peay
Oct 24, 2010.
Well my question is how come when I put the old o2 sensor in the one thats giving me the check engine light it satrts up perfectly and runs but it does idle a little high but stil runs and drives until engine warms up then it starts to shut off when I come to a complete stop

Tiny
Marquis.peay
Oct 24, 2010.
The oxygen will not cause an engine to stall if there's a problem to it, it will cause the engine to run rich that's all its gonna do-

Why don't you check the voltages on it if its switching accordingly-could be the computer itself, wrong type O2 sensor

Rasmataz
Oct 24, 2010.
Im just confused because the o2 sensor thats throwing the code seems to be the only one that makes my car start and run somewhat decent I just dont get why when I put a new one in you would think it would run better but its runs worst its weird

Tiny
Marquis.peay
Oct 24, 2010.
Hi I'm Ervin and, I have a mitsuvichi eclips GST 1995. The problem its that RPM gage up and down when it turns on and, I have to keep aselereting or it will turn off by it self, what can, I do

Tiny
Nivre
Oct 2, 2012.

AD