Mechanics

ENGINE RUNNING ROUGH

1990 Mitsubishi Eclipse

Engine Mechanical problem
1990 Mitsubishi Eclipse 4 cyl Front Wheel Drive Manual 85,649 miles

I have a 1990 eclipse with a swapped 1.8 liter cyclone engine in it with 85,649 miles on it (the valve cover says cyclone on it). I bought it with the swap already done. The problem is that when I start it, the idle is all over the place, going from 1100 rpm down to 500 and almost stalls out - when it warms up it stays around 1100 but fluctuates constantly. When I'm driving, if I give it about 1/4 throttle it runs ok but if I let off to idle/coast, its like the engine boggs down and jumps forward. Decelerating is fine, its just the little bit of gas that it boggs down. Also, my oil pressure is always really low when I'm idling. When I gas it, it comes up to just under the lower mark on the gauge. I've replaced the spark plugs, wires, distributor cap, and patched up all the exhaust incase it was a backpressure issue. The plugs seemed to be coated with carbon on them. Also, if it has been sitting over night, it will start right up and idle fine, but if I shut it off and restart it, the idle is all over the place again. I can't put a finger on what could be wrong. Any insight is greatly appreciated.
Thanks, Allan
Avatar
Allank5310
July 29, 2008.




The plugs seemed to be coated with carbon on them-Do a compression check both dry and wet and comeback with the readings.

If you wish start with the idle speed control servo, airflow and throttle position sensors check it by using a repair manual.

Tiny
Rasmataz
Jul 29, 2008.


AD