Mechanics

FUEL PUMP PROBLEMS?

1993 Chevrolet Astro • 6 cylinder 2WD Manual • 150,000 miles

I have a 1993 chev s 10 and dont have any power to the fuel pump 9WHICH I REPLACED THINKING IT WAS BAD ALONG WITH THE FILTER AND RELAY) and I also dont have juice to the relay, is there a fuse/ I ran a wire direct from the battery to the pump and it pumped fuel to the carb but when I cranked it over to start it no fuel came out of the two injectors? P.S. Starts up with starting fluid and is a V-6
Avatar
Tonycam
December 16, 2010.




Check the fuel pressure with a gauge if its within specs-no fuel on the injector use a noid lite on the injector harness and check if the injector circuit is functioning if not could be no power to the injector or the injector driver circuit on the computer is defective

Rasmataz
Dec 16, 2010.
What does fuel pressure have to do with it? It has power to the two injector, but there is no power to the fuel pump relay or to the pump and when hot wiring the fuel pump it gets pressure to the top but when cranking the two injectors or gas sprayers are not spraying gas into the throttle body
AD

Tiny
Tonycam
Dec 17, 2010.
EFI system has to be in specs in order for your vehicle to run right-

It has power to the injectors-but its not energizing providing fuel-sounds like computer driver circuit for the injectors-no power to the relay and pump-check the fuel pump fuse-

Rasmataz
Dec 17, 2010.
I got it thanks, the ecmb fuse was blown, when I put the new fuse in then the wires to the oil sending unit started smoking ( 2 grounded out on frame) the circuit runs thru the sending unit and contols relay and pump thanks rasmataz

Tiny
Tonycam
Dec 17, 2010.
Did you get it going or still having problems?

Rasmataz
Jan 4, 2011.

AD