Mechanics

CRUISE AND TRANS

1993 Cadillac Other • V8 FWD Automatic • 120,000 miles

1993 Fleetwood 60 special, I have a few problems. I don't have power to the a/c relay but it cools if I put power to it. Also the cruise doesn't work and the trans is running in safe mode. I've replaced the ECM but not the PROM. The speed sensor has been replaced and the TPS checks good. All the solenoids in the trans check well within range and all the fuses are good. All this happened at the same time. My book doesn't show any fusible links where it says they should be.
Avatar
Hank2349
June 26, 2011.



The a/c progamer controls this. Its behind the glove box. Also the cruise is operated on vacuum. Check the codes by pushing off and warmer on the a/c panel until you see all segments lit. Then the codes are on the fuel panel. It will cycle through the computers

Cadieman
Jun 26, 2011.
I should have added this but I've done so many tests I've lost track. I replaced the BCM when I had a blower problem. There are no codes showing for anything remotely close to these problems, I've pulled them and had a shop pull them. The only things that come up have to do with traction control and ABS. Have anything else I can try? I'm a retired certified mechanic but Cadillacs I don't have experience with and a Haynes manual only goes so far. Thanks so much for your responce, if we can fix this I'll double what I usually give ($20)+ $20

Hank2349
Jun 26, 2011.
You will need to replace the a/c programer. This controls the blower motor. The cruise lever works at times per you. Check were the lever plugs in on the column. If ok you will need to replace the lever.

Cadieman
Jun 29, 2011.
The blower motor works fine in any position and the cruise doesn't work. The trans is what bothers me more than everything. It seems to me that all these are electrical and my diagrams aren't very good.

Hank2349
Jun 29, 2011.
Does the cruise light go from yellow to green. The cruise and the trans are 2 seperate things. You need to check the vacuum at the cruise sevro. The small hose to servo seleniod should have vacuum. The large hose goes to brake pedal switch which is right above the brake light switch. If u can blow through the large hose you will need to adjust it so you cant. Also check the cable from the servo to the throttle body. When you operate the servo manually youll see the linkage operating the trottle.

Cadieman
Jun 29, 2011.
The cruise light doesn't come on.

Hank2349
Jun 29, 2011.
Are u getting vacuum to the cruise seloniod? Can u blow though the large hose at the servo. When u turn the cruise on at the lever does the light turn on the lever

Cadieman
Aug 9, 2012.