Mechanics

CAR WILL CRANK, BUT WON'T START

1988 Chevrolet Corsica • 82,358 miles

When it was still running, the speedometer would zero out, and the car would chug until it lost all power. After sitting for a while, it would start and run for a short time. The computer returned no codes what-so-ever. So, I checked the ignition, and found no spark. I replaced the module and coils, and have good spark. Car ran for 3 miles and gave a repeat performance. Towed it home, and checked fuel pressure; 43 psi before the regulator, and 9-13 after. The cylinders are returning 150+ psi compression. As the computer was unresponsive, I bought a replacement. The only thing out of the ordinary is the cooling fan kicks on as soon as the key is turned on without the engine starting. I traced the lines to find the relay. I was expecting to find some "creative" splicing that was feeding power into a data line, but nope. Any suggestions?
Avatar
Jp2464
December 26, 2011.



Do you have a TBI or a MPFI system? I'm confused with your fuel pressures

Rasmataz
Dec 26, 2011.
2.0l TBI

Tiny
Jp2464
Dec 27, 2011.
Check if the injectors are pulsing

Rasmataz
Dec 27, 2011.
One injector on TBI; yes, it sprays. I've also pulled the alternator and starter and had them tested at Advance. Both check out, so they were re-installed.

Tiny
Jp2464
Dec 28, 2011.
Verify the valve and ignition timing are correct

Rasmataz
Dec 28, 2011.
Cylinders are all producing 150+ PSI. Is that possible with valve timing off? Ignition timing is crank triggered. New module and coils installed. Wires are installed in correct order onto coil packs. The problem is intermittant it seems. As the battery was drawn down, it got progressively worse.

Tiny
Jp2464
Dec 28, 2011.
It seems that corrosion had formed on the connectors to the ECM. After using terminal cleaner and di-lectric gel, all seems to be normal. Thanks for the assistance.

Tiny
Jp2464
Dec 28, 2011.