Mechanics

CHEVROLET CAMARO TRANSMISSION PROBLEM

1983 Chevrolet Camaro • 278,000 miles

I have the transmission ready for removal but I cant get it to budge I checked and double checked to make sure all the bolt are out so that is not my problem. I tried to pry on in and spread WD40 around the bell housing to break up rust the may be around the housing. I also tried a chisel and hammer between cress and yet not nothing no movement at all. What would you recommend for me to do.
Avatar
Jerry1799
October 23, 2012.




It shold separte from engine if all bolts are out. There are about 7 or so. Is rear trans mount off? There is one at top if this is a V8. Make sure torque converter nuts are off from flexplate as well and converter shoved back from plate.

Hmac300
Oct 23, 2012.
Yes the rear mount is off but it is the 305 and what do you mean about one at the top near what

Tiny
Jerry1799
Oct 23, 2012.
The top of the transmission to engine mating surface right at the very top of the transmission. If you are trying to use a chisel and hammer to split the case from engine that is exactly what you will do split the case-break it. There still has to be a bolt connected someplace.

Hmac300
Oct 23, 2012.
I have already taken 4 bolts from the bell housing and 3 from torque converter the back of the transmission is already lose from everything sitting on the jack, is there anymore bolts that you can think of?

Tiny
Jerry1799
Oct 23, 2012.
Lower the trans and look at the top of the trans housing ther esholdbe abolt at thevery top You'll need a long extension and maybe a swivel to getit off.
AD

Hmac300
Oct 23, 2012.
Its dark here but will see what you are talking about in the morning thank you for your help and patience HMAC300

Tiny
Jerry1799
Oct 23, 2012.

AD