Mechanics

CHARGING SYSTEM

1988 Toyota Pickup

Electrical problem
1988 Toyota Pickup 4 cyl Two Wheel Drive Automatic 200780 miles

charge light came on and fuel, temp and radio quit. Put new inline fuse for radio now works. Put 2 reb. Alt. In # 1 no good (my luck) #2 bench tested and installed. Still nothing; checked relays, link-fuses all tested good. Traced wires everywhere everything looked good with ohm meter. Next removed all fuses all good. Hooked up bat. Put in both 7.5 amp. Charging sys. Fuses; started with alt. Found no juice at eng. Comp. Panel then nothing on dash panel then found nothing from ign. Switch acc. Side. Is possible switch is bad. Is it wise to jump acc. Terminal. Or a better way to test it
Avatar
Bill hazard
August 22, 2010.




Hi bill hazard, Welcome to 2carpros and TY for the donation

Do this get a voltmeter and read the battery voltage-record it, now start the truck and read the voltage again, The voltage here should be 2 volts more than the reading before you start it up-Is this the case-let me know


http://www.2carpros.com/forum/automotive_pictures/12900_a1_20.jpg




http://www.2carpros.com/forum/automotive_pictures/12900_a2_20.jpg

AD

Rasmataz
Aug 23, 2010.
Already tested voltage just about every behind dash& hood, battery has 12.72-12.83 running or not but remove ground no charge no go. Coulld not find power between alt. And both 7.5 amp. Fuses, as I mentioned before. So I got brave and took apart the back of the switch and found a worn and partially burnt contacts for acc. Terminal. Sanded (400 gt ) and carefully scraped burn't area re-installed, started truck. Well guest what engine does't need battery except to start. Thank's for the wiring dia. You might want to include the ingition switch in the wiring dia. I still well replace switch. I have another problem, will contact you later to later. Email me with your name

Tiny
Bill hazard
Aug 23, 2010.
Rasmataz@2carpros. Com

Rasmataz
Aug 23, 2010.

AD