Mechanics

RUNNING PROBLEM

1993 Toyota Camry

I have a 1993 Toyota Camry 4 cylinder. I have replaced the plugs, wires, cap, and button. I have also cleaned the throttle body, and air cleaning system. The car idles fine, even after you put it in gear, but when you go to drive off no matter what gear forward or reverse starts to act like it missing, when you push on the gas like a normal person it spits and sputters, if you push on the gas easy and not to much at one time, it takes off fine, and will run fine as long as you don’t push on the gas to hard. It was running fine, but after I got off my 12 hour shift for work it starting running bad. I had to replace the exhaust right in front of the catalytic converter, and I have replace the radiator, transmission rebuilt, both front axles replace, trimming belt replaced, all with in the last 6 months, along with the plugs, wires, cap and button.

What could be the problem, and what do I need to do to fix it. It any parts need to be replaced checked etc. Could you please also include the location.

I just strated the car again, and now when you put it in gear it idles ruff, and still the same effect when you push on the gas.
Avatar
Grif
September 29, 2007.




Hello!
Question.
Its the " check engine light" on?

Seems to me like the maf or TPS sensors are not working propperly.

Let us know about the light.

Tiny
Fisherman
Sep 30, 2007.
None of the check engine lights are on. So do you think it still could be the maf or tps? Or does it sound like the fuel filter? Thanks for your assistance on this problem so far, all help is greatly appreacated.

Tiny
Grif
Sep 30, 2007.
Ok.
Now that we know.
Check engine off (it lite when you open the ignition?)
I ask you because a friend of my told me that his check engine was off and we find that it was burn out.
Well. Start replacing the fuel filter that its not that expensive and its very important.

Let us know how it works after that.

Tiny
Fisherman
Sep 30, 2007.
I replaced the fuel filter, the car starts fine, it even idels fine, you can reve the engine in park and nuteral, but when you put it in gear any gear and step on the gas it still suptters.
AD

Tiny
Grif
Oct 3, 2007.
Open up the MAF investigate the flap and do the bench test on it-ohm it out-when it checks out go to the TPS check its voltages both at close and open throttle.

This sensors corresponds in operation-one tells the throttle postion and the other tells the amount air its getting-

Also find the IACV clean it out-

At the diagnostic connector jump TE-1 to E-1 and read off the flash-got no.S on it give to us.

Tiny
Rasmataz
Oct 3, 2007.
Thanks I'll check them out, I need all the help I can get, thanks once again

Tiny
Grif
Oct 3, 2007.

AD