Mechanics

LOSS OF POWER WITH AC ON SUBA LEGACY

1993 Subaru Other

HI Guys! I have a 1993 Suba Legacy that has 124,635 miles I think 2.4 engine. ? The problem started at high speeds on freeway during acceleration. Around 65 -70 car would chug then go down to 0. I would turn off the car then back on and it would be ok. Now when going through town I can be at 30 trying to go 40 and it will lose power while my foor it on the accelertor. It has been hot and my ac has been running almost every time.
I just had timing belt and PS and ac belt and alternator replaced as well as battery. So I lose power at all speeds now and happens every day but not every time I drive.
I take it to mechanics and I cant get a straight answer. As a female I am concerned that I will get taken because those other repairs have not fixed the problem yet.
Please help!
Avatar
Dixiecheermom
August 20, 2007.




Does the car feel like it is running out of gas? If it did it could be the fuel filter. Cindy, are you somewhat mechanically inclined. I mean can you or someone you know change the fuel filter? It is located under the hood on the drivers side. It has two rubber lines going into the top of it. The fuel lines are under pressure so be careful loosening them and disconnecting them. Once the pressure drops down you can change the filter farely easily. On the filter there is a inlet and outlet so match them up.

M_H_RITZEL
Aug 20, 2007.
HI Yes I can do the fuel filter or actually get someone to help. As for running out of gas it does not feel that way. I keep accelerating but I lose power. The car shakes like it is going to break up but that probably feels that way because I am going so fast. The other thing it seems to happen after I accelerated and I am backing off the gas.
I will run to the parts place and get a filter and see if I can get some assistance with changing it. Thank you so much for your reply and I will leave positive feedback for you!

Tiny
Dixiecheermom
Aug 20, 2007.
Let me kno what happens

M_H_RITZEL
Aug 20, 2007.
Let me know what happens

M_H_RITZEL
Aug 20, 2007.
Well it did not work. I had help changing the fuel filter then my neighbor took it on the freeway and it died a few times. They put it in nuetral and started it then put it in manual and was able to get it back home. They said it felt as if the oil pressured dropped. I am not sure what that means. But the car shuts off when driving.
Any other suggestions would be grateful!
Cindy
AD

Tiny
Dixiecheermom
Aug 21, 2007.
You say they said they said it feel like the oil pressure dropped. What warning lights come on when this happens? Did you have this problem before the timing belt was replaced? Lets try something, disconnect the negative side of the battery. Leave it off for at least 10 minutes. After that time reconnect it, start engine and see if the computer will reset itself.

M_H_RITZEL
Aug 21, 2007.
All my lights came on because the car dies. Check engine is on all the time. Hapened 2 times before timing belt was replaced. Will try to reset the computer now.
Thank you!

Tiny
Dixiecheermom
Aug 21, 2007.

AD