Mechanics

GAUGES STOPPED WORKING.

Plymouth Voyager

1999 Plymouth Grand Voyager, 125K miles 3.3 FlexFuel
all my guates (gas, fuel, RPM, & Speed) along with the gear indicator and odometer stopped working. At first, (a few days ago), when I started the car, they would come on, the gear indicator would light completely up with the odometer reading all 8's and then it would go off. After a few miles, it would come back on again.
After yesterday morning, the guages no longer come on at all, even though the odometer and gear selectors still light up completely before going dark.
I've checked the fuses which are all fine. Any help would be greatly appreciated.
Avatar
Kdemers
January 22, 2007.



I have a 96 Plymouth Neon, 108K miles. I just use it for commuting. The speedometer has been iffy since summer. If you hit a bump it would stop working, but came back soon enough. It sat all weekend, but when I got in it for work the speedometer, fuel gauge, water temp were bottomed out and the odometer stopped turning. Is this a VSS problem or something else? Does it sound electrical? Any ideas please let me know.

Tiny
Lateman
Jan 23, 2007.
I think I *Might* have found the source of the problem (Time will tell on this one!). After running around for a few days with no gauges, I popped the hood and checked the power distribution block. Pulled and reseated the fuses and relays. Shortly after getting back in the van all the gauges came back on and have stayed on.
Not 100% sure this is the source (or just co-incidence), but will update.

Tiny
Kdemers
Jan 23, 2007.
120,000 3.0- I have exactly the same problem - all the gauges go off, check engine light is on. Did anyone find the solution to this? It is seems like a really common problem, but I haven't found any feedback that said, " hey, this fixed it!&Quot.

I sure would appreciate any feedback you can give!

Thanks, Kim : )

Tiny
Ksmolinar
Oct 12, 2007.

Tiny
C. J. Mack
Nov 5, 2007.