Mechanics

ERRORS P0130 AND P0150 ON MOTRONIC 2.8.3

1996 Opel Kadett

Computer problem
1996 Opel Kadett 6 cyl Front Wheel Drive Manual

Hi

The car is a 1996 Opel Kadett 200iS with a 3.2 v6 engine conversion. I was running a Omega B 2.5 V6 ECU but was using a Vectra B intake. I got hold of a complete Vectra ECU and loom and installed it. When Cruising at higway speeds the EML comes on as soon as you lift off the throttle. Codes recorded are P0130 and P1050. The old ecu a Motronic 2.8.1 did not give any errors. On the live dada file I saved the mv output of the sensors drop to 0. The car does not suffer from any drivability problems. Could a leak on the intake cause this or are the sensors not compatable with the Vectra ECU?

Thank You
Avatar
Disruptor565
July 5, 2010.



The sensors are not giving the correct readings for this ECU. You cannot just replace an ECU with one from another vehicle. They all have differing settings and values

Dave H
Jul 18, 2010.
I think I should have said that this was a full conversion with the loom and ecu from the vectra. But I suppose you guys knew that since the Motronic 2.8.1 from the Omega B uses a 55 pin connector on the ecu and the Vectra B ecu has 88 pins so I had to fit the loom. What I will do is replace the sensors as a last resort. The full setup is a Vectra 3.2 v6 motor with the Motronic 2.8.3 ecu and its loom fitted to a Astra F that had a 2L 8valve motor as standard.

I just tought is was strange that the Omega ecu did not show any problems. I suspect the heater wattage on the sensors are not the same as on the vectra since the part numbers are not the same.

Sorry for the confusion and thanks for the reply.


http://www.2carpros.com/forum/automotive_pictures/546569_15042010307_3.jpg



http://www.2carpros.com/forum/automotive_pictures/546569_24052010354_1.jpg


Tiny
Disruptor565
Jul 26, 2010.