Mechanics

MY CAR WONT START

2000 Mercedes Benz S500

Electrical problem
2000 Mercedes Benz S500 V8 Two Wheel Drive Automatic 154, 00 miles

I did not use my car for 3 weeks. And tried to start yesterday but it wont start. Theres no sign of light, wipers, radio and other. When I put the key in ignition key it wont turn. So I decided to use the the jumper with another car. The light went on, rado but it wont start.

Is the battery dead? But how come it wont start even I use jumper with another car? Or any electrical problem?

somebody can give me advice, thanks in advance.

therdy64.
Avatar
Therdy64
May 22, 2010.



Cranks but no start condition: Fuel and Spark: Get a helper disconnect a sparkplug wire or 2 and ground it to the engine at least 3/16 away from ground -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it.

No crank at all/nothing/nada: Could be a blown fusible link, the starter, starter relay, clutch switch/park and neutral switch and ignition switch assuming the battery and connections are good

Rasmataz
May 22, 2010.