Mechanics

ACCELERATION AND ESP PROBLEMS

2003 Mercedes Benz C320

Engine Mechanical problem
2003 Mercedes Benz C320 6 cyl Two Wheel Drive Automatic

When you first turn key to start it wont start, but if you turn key to on and wait for gages to light up it will start every time. Also when accelerating if you are steady it is fine, but if you slightly let off gas during then reapply gas pedal it hesitates and feels like you have no power, if you wait a few seconds it comes out of it. Then while driving on highway other night at 65 mph there would be a " jerk" the a few minutes later ESP light comes on and car shuts down. Came to a stop and restarted, runs fine. No check engine or malfunction light to code out. Help Please. Fuel filter? Air flow sensor? Steering sensor? Have researched a little and dont want to pay dealership a small fortune. Thank You
Avatar
Vicmax
May 18, 2010.




Could be an intermittent problem with ignition switch, Check the fuel pressure if its within specs. Could also be caused by the following

Oxygen sensor.
Catalytic converter.
Fuel injectors dirty/sticking.
Mass airflow sensor/Airflow meter.
Throttle position sensor.
Manifold absolute pressure sensor.
EGR Valve
Fuel pressure regulator leaking or defective fuel pump.
False air leakage.
Fuel contamination.
Foul/defective spark plugs.
Open spark plug wires.
Ignition coil/Coil packs defective.
Incorrect ignition timing.
Cap and rotor.

Note: If it doesn't apply disregard.

Tiny
Rasmataz
May 25, 2010.


AD