Mechanics

CHECK ENGINE LIGHT ALWAYS ON

1990 Mercedes Benz 300te

Electrical problem
1990 Mercedes Benz 300te 6 cyl Two Wheel Drive Automatic 225000 miles

despite having had a major service, a new transmission, a replaced BDU, O2 sensor, Cam sensor, I still have this problem.

Normal use around town at town speeds fine. However, when I go on the freeway and stay at higher speeds for a longer period the car rev counter plummets as I come off the exit and stalls. I can immediately re-start it but the tick-over goes lower and always feels like it wants to stall. Have tried endless visits to the shop with no cure as yet. The car runs fine in all other respects and is in great condition. Just need to cure this problem. The check engine light is constantly on and even after it is reset it usually comes back on within a day, followed by more stalling.

Any Ideas? Help!
AD
Avatar
Chriscw
June 7, 2010.




Hi chriscw, Welcome to 2carpros and TY for the donation

Have the computer scanned for code/s-you have a problem within the engine management system that caused the CEL to turn on-This is your starting point of diagnosis, finding out what's going on.

Rasmataz
Jun 7, 2010.
Hi. This has all been done, endless times, by so called specialists. The' starting point', the engine management system has been checked again and again and again! And the result has been the same. They say they have fixed it and a day later it comes back. With respect the shop I took it to said exactly the same thing, and five visits later and $1500 I am no better off. Sorry, but you'll have to come up with something a little more in depth please. Thanks. Chris.
AD

Tiny
Chriscw
Jun 7, 2010.
I'm sorry without me knowing what's triggering the CEL I'm unable to proceed

Rasmataz
Jun 7, 2010.

AD