Mechanics

NO SPARK OR FUEL PRESSURE.

2001 Mazda Protege

Engine problem
2001 Mazda Protege 4 cyl Front Wheel Drive Manual 94,000 miles

I have an '01 Mazda Protege MP3 no fuel pressure, or spark. Replaced fuel pump and coil/plugs, & still not running
(It is the 2.0 engine) What first happened was one of the coils stopped working. The middle 2 cylinders were not getting any spark. Replaced the coil and it fixed that. Ran perfect, for a little less than a mile. While I was driving I didn't notice my engine wasn't running (radio) I looked at the RPM gauge and it was at 0 so I gave it some gas and the guage didn't move, nor did I accelerate. Turned the radio off and then realized it wasn't running. It was still in gear but it just wasn't getting any fuel. Pulled it to a garage and started diagnosing the problem. Disconnected a fuel hose by my engine and it wasn't getting any fuel, so we replaced the fuel pump, didn't do anything. Still no fuel. Also checked the plug wires for spark and it's not getting power. Checked the crank/cam shaft sensor to see if it was getting power, no power to either sensor. Replaced the master power relay fuse, still not working. As far as any codes. We hooked it up to their high speed computer. Only code that came up was the oxygen sensor. I purchased it used a year and a half ago, it's been throwing the o2 sensor code since I first got the car. If anyone can assist me with this I would greatly appreciate it!
AD
Avatar
Njmorris
December 30, 2007.



I would start looking at the crank sensor
and check relay and power supply
also do you have check engine light on when turning key to on
if no start looking at wiring and relays

BMRFIXIT
Dec 30, 2007.


AD