Mechanics

WIPERS DOME LIGHT 4X4 SWITCH INTERMITANT

1998 Mazda b4000

I have noticed that at times the wipers, dome light and 4x4 selector switch do not work. Sometimes they will start working while I am driving. All fuses are good. I had a local shop check for codes while the problem was ocuring but nothing showed up. While the scanner was hooked up the wipers made one pass then the problem continued.

I have not noticed any correlation to outside temp, engine temp, or other electrical functions.

Is this the GEM or Body Computer module? Anything else I should check before replacing that?
Avatar
Nozzano22
March 15, 2010.




Could be, but it could also be a bad ground Check at these two locations. I will send you the wiring diagram, also check the connectors at each part...


http://www.2carpros.com/forum/automotive_pictures/62217_grounds_1.jpg

AD

Merlin2021
Mar 15, 2010.
I located a used GEM but will try your suggestions first.

It does seem odd that it is intermitant. I would think the GEM would either work or not.

Are these ground straps found inside the engine bay of the vehicle? If I remove, clean and reinstall is that adequate?

Should I also check, clean the GEM connectors? Dielectic grease?

Mike

Tiny
Nozzano22
Mar 15, 2010.
Grounds are under the hood, remove the negative battery cable, then work on your connectors and grounds, very light on the dielectric grease, and plug em back in. Clean the grounds, but dont remove any paint on the grounding surface.

Merlin2021
Mar 15, 2010.

AD