Mechanics

BATTERY AND FUSE QUESTION -

2002 Jeep Liberty

Hi. My 2002 Jeep Liberty with 77,500 miles on it needed the battery changed. Green stuff was coming out of it and the car died last night (in the garage). I could not jump it. It was dead as a doornail. So today, I took the battery out and replaced it with a new one. Got my battery connections hooked up and started the car. It started without a problem and I then drove 20 miles to pick up my wife at work. No problem . Car ran fine. But on the way back after getting her, I noticed the speedometer was not registering at all, the radio (and clock) were not working either, the fog lights did not come on (all other lights are fine) and the windshield wipers do not work, but the windshield fluid sprayer is fine. I then thought a fuse might be out. I checked them all and found one 10amp fuse blown. I replaced it and it immediately blew out again. So, I then rechecked my battery connections up front and they appear to be fine and the car runs just fine. But. My speedometer is out, my radio and clock is out, my fog lights are out and my wipers do not work. What could be the cause? Do I have to take this to my Jeep dealer, I hope not. They always cost a fortune. Thanks for any help you can provide.
Avatar
Mrmsu1952
November 1, 2007.




I checked them all and found one 10amp fuse blown.

Give me what it pertains to and I'll see what I can do to unclick for you.

Tiny
Rasmataz
Nov 1, 2007.
Wow. Thanks so much for your very fast reply and help. Here is some more info for you. While I was away from the computer just now, I took the car over to my local auto place that was still open and asked the guy there. He had no clue. But, since I had a Check Engine light on (which I forgot to mention before), he hooked his diagnostic computer to my car cable (if that is what you call it) and he gave me the following. DTC Codes = P0500, Vehicle Speed Sensor A - Malfunction. I guess that is simply telling me what I already know. My speedometer is not working (which I knew). So that is the only code that is coming up. Now, regarding the blown fuse. It is #32 in my Jeep Handbook which means. A 10amp red fuse = Radio, Front Door Lock Switches and Body Control Module (whatever that is). This makes sense since my radio is not working. But, my power front door locks are working just fine. So, I am confused. Any help you can provide is greatly appreciated. By the way, I am in Gadsden, Alabama.
AD

Tiny
Mrmsu1952
Nov 1, 2007.

AD