Mechanics

HARD START AND ROUGH IDLE COLD

2001 Hyundai Accent

Engine Performance problem
2001 Hyundai Accent 4 cyl Two Wheel Drive Automatic

I have a Hyundaii Accent 2001 with a 1500cc single
cam engine, my problems are these is hard to start cold
iIhave to put the gas pedal to the floor it's shutter
buck for about 1 minute or so and then the idle come on 800rpm or so and there is no power on the engine I can't put it in gear it's stall.I start the engine
again then idle is ok, on the road the transmission is harsh to shift, As soon as the motor is hot those problems are gone. Those problems gradualy worsen over the months.I have change the
2 coil(one was arking), change the fuel pump assembly
the pressure cold was 35psi, change the ISC modulator, clean the MAf.I have tested the injectors with a noid light the 4 have a flash, sparks on the plug are blue.I have open the Pcm and ne corrosin inside and no loose connectors. Codes of the PCM are all cylinders misfire
300 to 304, p1128 fuel system lean part load and that's it,
Sorry for the english I am from Quebec: a frenchie
Thanks for helping me out
Avatar
Alain57
September 4, 2010.



Hi alain57,

Thank you for the donation.

Symptoms indicates a possible fault with engine compression.

Do you have overheating or coolant losses issues?

Get a compression test to confirm if there are any cylinders that is/are below specifications.

If valve clearance are adjustable, check their clearance and adjust if necessary.

KHLow2008
Sep 4, 2010.
I verify the compression 175psi to 180psi on all 4 cylinders

Tiny
Alain57
Sep 10, 2010.
Compression pressure are within specs.

Were the spark plug wires tested? Check their resistance, should be less then 25k ohms with continuity. The arcing coil is an indication it could be bad wires.

A lean condition could mean a bad MAF even though it might not throw a code as it is working but out of specs.

KHLow2008
Sep 13, 2010.
Spark plug and wire set are brand new, the coil was crack
I will try a MAF and see

Tiny
Alain57
Sep 13, 2010.
Keep me informed of the outcome.

KHLow2008
Sep 13, 2010.
After all the money spent on ther car; $1,000 finally
the car run ok
many thanks

Tiny
Alain57
Sep 26, 2010.
Glad to know you have fixed the problem.

What did you do to get it fixed?

KHLow2008
Sep 27, 2010.
Change the MAF sensor

Tiny
Alain57
Oct 11, 2010.
Thanks for the input.

Have a nice day.

KHLow2008
Oct 11, 2010.