Mechanics

SEVERE HESITATION AND FLAT SPOT AFTER HEAT SOAK

GMC Sonoma

I have a 2003 Sonoma 4.3l vin: x 35000 miles on it. And it's a 4x4. I have a hesitation Slight) most times. Put the major problem is When first started in a.M. It runs fine. But drive a couple of miles then stop go in store or anywhere and come out about 15 to 40 min. Later and start truck, back out of spot and depress accelerator and nothing. You can sure hope somebody knows Please Help put throttle to floor and truck just creeps. If you pump throttle it sometimes backfires through intake. After you get moving it's ok but still has a little hesitation. I Have changed fuel filter twice in a couple of months, removed masf and cleaned with masf cleaner, removed throttle plate body and cleaned with throttle cleaner, replaced dist. Cap and rotor. Had to dealer, it did same for them, and they can't find out why. Checked fuel pump pr. With key on = 60lbs, started engine had 55 lbs. Reved eng. Stayed at 55 lbs. Added water remover and fuel injector cleaner to tank, no help. Please Help Thanks. Ron
Avatar
Plain stumped
August 6, 2007.




Is the check engine light on? Not sure if it is related, fuel press should have jumped when engine is revved, that problem could be the fuel pressure reg blown causing the lines to bleed down. Might even be the cause of the hesitation not having the pressure come up upon hard throttle.

Tiny
Jack42
Aug 7, 2007.

Tiny
Plain stumped
Aug 7, 2007.
No service engine soon light. It only happens after engine is up to temp and a short stop ( 10 to 40 min) Then runs fine except for slight hesitation sometimes. In park, fuel pr. Was 60 lbs. Rev engine, dropped to 55lbs. No matter how high reved. Runs down highway fine. Other than slight hesitation, accels hard, downshifts to passing gear and accels fine. Just that flat (No fuel) like symptom after restart. On the 4.3L the fuel reg. Is under the plenum. How can it be checked further? Sopmetimes truck accels so well it will break back tires loose then sometimes it accel like a 4 cyl. The dealer said to drive it until it breaks or sets a hard code ( mil light on). But it's dangerous to pull out into traffic with that flat spot HELP! Thanks ron
AD

Tiny
Plain stumped
Aug 7, 2007.
The reg is under the plenum. Almost sounds like a pump problem, sometimes up to par and sometimes not. Pressure should jump up when engine is revved, not drop. Start with the reg, cheapest and easiest to replace, dealer will have them in stock

Tiny
Jack42
Aug 7, 2007.
I bought a new fuel pr. Gage and hook it up. Ran line under hood and taped gage to windshield. After about 15 min. Started engine = 60 lbs pr. Backed out of driveway and put in drive. Stepped on throttle, almost to floor. About or at least 75%. NO acceleration, completely flat after about 2 to 3 seconds truck picked up speed. Fuel pr. Never dropped. In fact it went back up to 60 lbs. (Went down to 55 lbs after engine first started. Tried hard accel. After flat spot, hesitated but acceled well. Tried passing gear from about 25 MPH, it was fine. Fuel pr. Went up to 60lbs and didn't drop until I let off throttle. Then only droped to around 50 lbs. It doesn't appear to be fuel related. Put temp related because the engine and engine compartment temps rise after shutting down from driving. That is when it does it, after sitting for 20 to 30 min when I stop and then try to go somewhwere. HELP! Thanks Ron

Tiny
Plain stumped
Aug 8, 2007.
I had a Monte Carlo do that to me and it was the cat converter, would idle fine and run ok sometimes and others wouldnt accelerate. Do you have access to a scanner that shows live data? Be nice to watch TPS and the such to see if they are working properly. Also look at the main PCM harness near the battery where it crosses over from the engine. There is a hose clamp on the heater hose near the harness that I have seen rub the harness causing all sorts of strange problems

Tiny
Jack42
Aug 9, 2007.

AD