Mechanics

ENGINE NOISE UNDER LOAD AND AFTER STARTING

2005 GMC Sierra

Noises problem
2005 GMC Sierra V8 Two Wheel Drive Automatic 70000 miles

I have a 2WD GMC Sierra pickup with the 5.3L V8. Recently, it makes a grinding like noise when I start it up and is in park. It goes away shortly after I start it up but shows up again when the engine is accelerating at any speed.

It does not throw an engine code, and the alternator is giving 14 volts, the power steering appears to be working fine (cant feel any resistance) and my brakes feel fine. My wheel bearings and ball joints are ok. I just had to replace my front passenger side wheel hub and bearing because it blew out. Does not seem related because the front suspension is isolated from the engine. No visible dents or damage to the engine bottom, but it is very muddy, I had driven off-road with it.
Avatar
Amraam35
March 14, 2010.




No engine codes, the engine mounts appear in good shape. I took off both accessory belts and that did not change the problem. My harmonic balancer pully (pulley powered by the engine) looks like it is slightly offcenter, (est. 1-2 mm wobble).

Tiny
Amraam35
Mar 14, 2010.
When you hear the noise, does it change with RPM's?

Let me know. Also, could the sound be coming from the rear of the engine?
AD

Turned out a had a big rock lodged between my exhaust and frame near my transmission. Could not see it until I got it up on a lift. Runs great now that its gone. Thanks for the help.

Tiny
Amraam35
Mar 16, 2010.
That is good. An easy fix.

Let us know if you have questions in the future.


AD