Mechanics

TRUCK STARTS AND IDLES FOR SECOND THEN QUITS

GMC C1500

Hello My name is Robert. I own a 1999 gmc c1500 pick up 2 wd 5.7 ltr 350engine 118,000 miles.
It ran great saturday but it sat most of the weekend and monday morning would not run. It will start for a few seconds as long as you do not press accelerator peddle but will quit every time. If you press the accelerator peddle it quites immediatly and very violently. Some times while trying to get it to crank over it almost sounds like it is blowing out the carborator or will make loud noises like it suddenly changes direction maybe a missfire not sure it has never done this before. Like I said saturday it ran fine monday morning it wouldn't go anywhere. Also strong fuel smell while trying to start it.
The ignition coil is brand new as well as distributer cover, rotor, spark plug wires and just put a new alternator on about a week ago. Spark plug maybe six months ago when I put on headers. Any ideas suggestions will be very appriciated.
Avatar
Robert p
August 15, 2007.




Do you have spark to the plugs. I would wager that you do and since you have the gas I might look at a camshaft position sensor or a crankshaft sensor. Check the vehicle for any codes at the computer.
AD

Bruce Hunt
Aug 15, 2007.
The truck will not stay running long enough for any of the indicator lights to turn off. Tried to spray carberator choke cleaner into it but no change. Checking vacuum lines.
Will check sensor.
Thanks

Tiny
Robert p
Aug 15, 2007.
Replaced camshaft position sensor found loose ground wire between engine and firewall reattached that still no change. I also said truck idles for a second let me clarify it idles but is a very rough idle barely enough to keep engine turning spraying carb/choke cleaner will speed the idle up but not really prolong it. Most of the time it will crank over just to shut down as soon as you release the key. It sounds like it wants to start but then you hear loud squeaking noise and smoke and air shooting out of carberator even caught on fire once due to me leaving brake vaccuum hose off. And as for codes on computer don't know how to do that? Do I need a special tool?
Thank you

Tiny
Robert p
Aug 15, 2007.
Got code p0102 ( m.A.F sensor input low) replaced m.A.F sensor, replaced map sensor replaced oxygen sensor, ignition coil is only a couple months old as well as spark plug wires distributer cap and rotor. Spark plugs are about six months old. I cleared all codes and after replacing all that no more codes yet the truck will start want to run idles at about 1000 rpms but quickly lowers to a rough idle or quits almost as soon as you take your hand off keys. After a few tries there is a fuel smell that comes out of the exhaust. Any idea's on what might be wrong?

Tiny
Robert p
Aug 17, 2007.
Founf the problem, Distributer was cracked and wouldn't hold the cap, it would tighten but as soon as it vibrated would pop off causing the engine to misfire, so replaced distributer, distributer cap and rotor and truck runs like a champ again.

Tiny
Robert p
Aug 27, 2007.

AD