Mechanics

BAD SHAKING/ SLIPPING OR SOMTHING?

2001 Ford Taurus

Transmission problem
2001 Ford Taurus 6 cyl Two Wheel Drive Automatic 140000 miles

car has always had a very slight missfire while at stop lights. Recently my check engine light would come on when I warm my car up in the morning it happened twice in two weeks code was a random misfire. When leaving a freinds earlier I put it in reverse engaged fine then to drive seemed a little delayed so I takeoff give it gas and it seems like my tranny slipping rpms 3000 and a very bad shaking so I keep it at 1200 and its alright but slow go up a steep hill tranny shifts rpms go up and shaking starts again let off gas goes away so I rev it to 3500 4000 next time it happens shaking goes away shifts fine but then im too fast. Changed coils still there but maybe not as bad. I have already have changed iac valve egr valve and passage and sensor sparkplugs and wires less than a year ago. I have a slight ticking and a very slow coolant leak that I cant see where its coming from maybe around cylinder head im not sure where should I start is my tranny shot? Please help im broke and still owe 1000 on the car. Also besides above described it ran and shifted smooth till I left my buddies. Tranny fluid was 1/4 the way up the hatch marks but it says not to add any right? I have also changed tranny fluid and filter year ago
Avatar
Suttona
January 22, 2010.




Check coil if firing all cylinder s

check and get the codes
codes should help in pointing to the correct troubled area
let me know what you have for codes

BMRFIXIT
Jan 24, 2010.


AD