Mechanics

4.7L

2000 Dodge Dakota

I just put a new engine in this truck and it will not start. I have replaced the cam position sensor and it still will not start. I pulled a P1391 code and the book dosent even show this code. Any ideas would be great. The timing is right : cry:
AD
Avatar
Krash
November 17, 2007.



Try crank sensor

P1391 Intermittent Loss of CMP or CKP

BMRFIXIT
Nov 17, 2007.
Replaced both sensors. Should I disconnect the battery/ will this reset the computer?
AD

Tiny
Krash
Nov 18, 2007.
What about the ring that is behind the camshaft gear?What is the chance this is bad? Dont really want to pull this motor back down but, will if I have to.

Thanks

Tiny
Krash
Nov 18, 2007.
Did u make sure of the wiring
is it all pluged in and nothing get damage whille installing the engine

BMRFIXIT
Nov 18, 2007.
Did u make sure of the wiring
is it all pluged in and nothing get damage whille installing the engine[/quote: a306f003d5]
On the 4.7 u can remove the cam sensor and inspect the wheel
if loose or damage
tone wheel is located under CAM SENSOR IN FRONT ENGINE PASS SIDE

BMRFIXIT
Nov 18, 2007.
I am pretty sure everything is plugged in. I have removed th valve cover and can see the sensor and the wheel. The wheel is not loose and the plate is not bent, other than that I am not sure what kind of damage to look for.

Tiny
Krash
Nov 18, 2007.
Ok lets start over
truck no start after new engine install
do u have fuel pressure
do u have spark
do u have injector pulse
did u check the ASD relay
unplug and plug the BCM
because the code u have it may be only that the cam and crank sensor are not in sync
let me know

BMRFIXIT
Nov 18, 2007.

AD